Linux on Virtex board with ARCH=powerpc

Peter Mendham petermendham at
Tue Jun 24 19:02:23 EST 2008

Dear all,

I'm trying to boot a 2.6.26-rc6 kernel on a custom Virtex 4 board.  I 
have used the Xilinx utility to generate a device tree and now want to 
generate an image for throwing onto CF for use with a SystemACE (just 
like on the the ML3/4xx boards).  I don't want to use a bootloader (I 
don't really need one).  I saw something on this list about simpleImage, 
"simple" sounded good to me so I thought I'd try that (or did I 
misinterpret what this is for?).  I also don't want the image to be too 
big, I always used to use a zImage under ARCH=ppc. So, two questions, 
which hopefully are easy ones:
1. I did what Grant said in a post to this list about simpleImage, and 
dumped my dts into arch/powerpc/boot/dts and I called it system.dts (for 
now).  I then tried to do make simpleImage.system which ran right 
through to final link then moaned about a missing simpleboot-system.  
Where is this supposed to come from?  What am I doing wrong?  I naively 
tried copying simpleboot.o to simpleboot-system.o and the error went 
away.  Hmm.
2. I need an ELF to give to my SystemACE file generator.  This used to 
pop up in arch/ppc/boot/images and be called zImage.elf, which made 
sense to me.  What's the deal now with powerpc?  What should I be using?
Finally, can anyone give me a heads-up on any gotchas with what I'm 
trying to do.  As you can tell, I don't entirely know what I'm doing, so 
any pointers would be gratefully received.

-- Peter

The University of Dundee is a Scottish Registered Charity, No. SC015096.

More information about the Linuxppc-embedded mailing list