[Skiboot] [PATCH 2/4] hdata/i2c: Replace i2c_ prefix with dev_

Andrew Donnellan andrew.donnellan at au1.ibm.com
Fri Apr 27 11:55:11 AEST 2018

On 24/04/18 13:25, Oliver O'Halloran wrote:
> The current naming scheme makes it easy to conflate "i2cm_port" and
> "i2c_port." The latter is used to describe multi-port I2C devices such
> as GPIO expanders and multi-channel PCIe hotplug controllers. Rename
> i2c_port to dev_port to make the two a bit more distinct.
> Also rename i2c_addr to dev_addr for consistency.
> Signed-off-by: Oliver O'Halloran <oohall at gmail.com>

Reviewed-by: Andrew Donnellan <andrew.donnellan at au1.ibm.com>

Andrew Donnellan              OzLabs, ADL Canberra
andrew.donnellan at au1.ibm.com  IBM Australia Limited

More information about the Skiboot mailing list