[Skiboot] [PATCH] core/pci: Rename pci_slot_op poll to run_sm

Stewart Smith stewart at linux.vnet.ibm.com
Wed May 31 21:22:03 AEST 2017

Michael Neuling <mikey at neuling.org> writes:
> This renames the "poll" op to "run_sm" (short for run state machine).
> I think this is a better name since the function does a bunch of
> things like reseting the slot.  Also it avoids confusion with the
> "poll_link" op which does something different (and can even be called
> from run_sm).
> No functional change.
> Signed-off-by: Michael Neuling <mikey at neuling.org>

9abb449b9c572e98002a8a500afcc3958d829297 and all makes a bit more sense.

Stewart Smith
OPAL Architect, IBM.

More information about the Skiboot mailing list