[Skiboot] [PATCH v1 0/5] New HBRT interfaces

Stewart Smith stewart at linux.vnet.ibm.com
Wed Aug 19 09:26:47 AEST 2015

Patrick Williams <patrick at stwcx.xyz> writes:
> What we decided to do with the HBRT interface was to change the name to
> 'mfg_htmgt_pass_thru' to indicate that this interface is meant only for 
> manufacturing interfaces and gives no warranty of backwards or forwards
> compatible behavior.
> Would it be reasonable to make the extra option "--mfg" which enables
> special test and manufacturing-only interfaces?  I believe the proposed
> 'run_command' would also fit this.
> On Fri, Aug 14, 2015 at 08:25:12AM -0500, Daniel M Crowell wrote:
>> So this "--enable-danger-mode" would be required upon initial invocation 
>> of opal-prd or as part of sending a command?
> My preference would be that this option is given on invocation of the
> command requiring the extra option, not on invocation of opal-prd.  My
> understanding is that opal-prd will typically be launched from a system
> service.  It would be cumbersome to make manufacturing restart the
> service in a special mode in order to utilize these commands.

Mine too.

My desire is to have something that stands out so that if somebody
pastes you a series of commands and you see "--danger-mode"[1] or
something you *immediately* know what's going on: either there's a bug
relating to manufacturing or the reporter gets to keep both pieces.

It also means that we just completely pass the bug report on to htmgt :)

[1] while "--manufacturing-mode" may be more accurate, "--danger-mode"
    makes me smile and giggle significantly more.

More information about the Skiboot mailing list