[Skiboot] [PATCH v1 0/5] New HBRT interfaces
patrick at stwcx.xyz
Wed Aug 19 09:06:11 AEST 2015
What we decided to do with the HBRT interface was to change the name to
'mfg_htmgt_pass_thru' to indicate that this interface is meant only for
manufacturing interfaces and gives no warranty of backwards or forwards
Would it be reasonable to make the extra option "--mfg" which enables
special test and manufacturing-only interfaces? I believe the proposed
'run_command' would also fit this.
On Fri, Aug 14, 2015 at 08:25:12AM -0500, Daniel M Crowell wrote:
> So this "--enable-danger-mode" would be required upon initial invocation
> of opal-prd or as part of sending a command?
My preference would be that this option is given on invocation of the
command requiring the extra option, not on invocation of opal-prd. My
understanding is that opal-prd will typically be launched from a system
service. It would be cumbersome to make manufacturing restart the
service in a special mode in order to utilize these commands.
-------------- next part --------------
A non-text attachment was scrubbed...
Size: 819 bytes
Desc: Digital signature
More information about the Skiboot