[PATCH v2 4/5] drivers/mailbox: Add aspeed ast2400/ast2500 mbox driver
cyrilbur at gmail.com
Tue Jan 10 09:09:00 AEDT 2017
On Sun, 2017-01-08 at 15:45 -0600, Benjamin Herrenschmidt wrote:
> On Tue, 2017-01-03 at 11:54 +1030, Andrew Jeffery wrote:
> > > > I think we should rename the IOCTL as what we do below doesn't
> > > > necessarily raise an interrupt.
> > > >
> > >
> > >
> > > Agreed, taking unput :). ASPEED_MBOX_IOCTL_WRITE_BYTE ?
> > That suggestion works for me.
Sorry about the blank one, I'll try typing something this time.
> If we are going to do that, maybe we should make this a write()
> at a specific lpos...
Andrew, Joel what do you think of this, a write of count 1 at a
specific pos. I like this since it removes ioctls all together and
isn't any harder for userspace.
> Otherwise call it something like SET_ATTN or SET_FLAGS ...
More information about the openbmc