[PATCH v2 4/5] drivers/mailbox: Add aspeed ast2400/ast2500 mbox driver
andrew at aj.id.au
Tue Jan 10 09:55:04 AEDT 2017
On Tue, 2017-01-10 at 09:09 +1100, Cyril Bur wrote:
> On Sun, 2017-01-08 at 15:45 -0600, Benjamin Herrenschmidt wrote:
> > On Tue, 2017-01-03 at 11:54 +1030, Andrew Jeffery wrote:
> > > > > I think we should rename the IOCTL as what we do below doesn't
> > > > > necessarily raise an interrupt.
> > > > >
> > > >
> > > >
> > > > Agreed, taking unput :). ASPEED_MBOX_IOCTL_WRITE_BYTE ?
> > >
> > > That suggestion works for me.
> Sorry about the blank one, I'll try typing something this time.
> > If we are going to do that, maybe we should make this a write()
> > at a specific lpos...
> Andrew, Joel what do you think of this, a write of count 1 at a
> specific pos. I like this since it removes ioctls all together and
> isn't any harder for userspace.
I'm in favour of removing the ioctl. So the logic would be:
1. If lpos is zero, assume a MBOX_NUM_DATA_REGS-sized write as we do
2. If lpos is non-zero, assume a single byte write
On that, should we be testing the assumptions about buffer sizes?
Currently we don't (we use the MBOX_NUM_DATA_REGS rather than count).
-------------- next part --------------
A non-text attachment was scrubbed...
Size: 801 bytes
Desc: This is a digitally signed message part
More information about the openbmc