on G5/1.8 (9,1)

Keith Mitchell kamitch at cisco.com
Thu Mar 9 13:00:40 EST 2006


I have a bunch of different powermac machines that I am trying to 
upgrade and/or install and am having some difficulty with the 1.8 (9,1) 
powermacs as well as the newer Dual Core (2.0) machines.  The other two 
types of machines that I have seem to be working well enough (Dual-Proc 
2.0, Dual-Proc 2.7 -- Both 7,3).

Originally the systems were running a beta version of Yellowdog that had 
a custom kernel based on  That kernel works great on all of 
the machines except the dual core which doesn't work at all with the 
kernel (no surprise).  When YDL 4.1 came out (with a kernel based on 
2.6.15-rc5 plus some patches) I wanted to upgrade to that and have the 
same image on all of the machines.  The hope was that the 1.8ghz-single 
machines would get thermal support and I would get rudimentary support 
for the dual core machine.  I want to have the same load on all of the 
machines to make my job easier (since I have 30+ machines total to keep 
running).  But... The stock YDL kernel does not work so well on the 
1.8ghz-single machines.... I am able to install the distribution on 
these machines and reboot.  The system will stay up for something like 
30 seconds and then it freezes and shows:

hda: lost interrupt
mipc_enable_irq timeout

The dual core machine does something a little different.  I logged onto 
the console and tried to run Xautoconfig and I used tab completion and 
then it starts scrolling that all up the screen and occasionally I see 
the above errors but then it keeps scrolling and I can't use the machine.

Then I tried to use the stock kernel that I d/l'd from 
kernel.org.  At first I tried to use the 'arch/powerpc/g5_defconfig' but 
that wouldn't compile, so I tried 'arch/powerpc/ppc64_defconfig' and 
that didn't compile either (same error).  So, then I tried taking the 
config file from the YDL srpm (i.e. 2.6.15-rc5 based) for the kernel and 
tried that (the g5-smp version) running it through 'make oldconfig' and 
taking the default for the new options.  This kernel compiled but 
wouldn't boot at all.  It went through the PROM code, cleared the screen 
and showed me the little logo at the top of the screen and then a 
blinking cursor but nothing after that.... This was on the single-1.8 
machine... I did not try this on the Dual-core machine or the Dual-Proc 
machines due to lack of time today.

FWIW the compile errors I got from the defconfig compiles was:

drivers/md/raid6int8.c: In function `raid6_int8_gen_syndrome':
drivers/md/raid6int8.c:185: error: unable to find a register to spill in class `FLOAT_REGS'
drivers/md/raid6int8.c:185: error: this is the insn:
(insn:HI 619 621 640 4 (set (mem:DI (plus:DI (reg/v/f:DI 122 [ p ])
                (reg/v:DI 66 ctr [orig:124 d ] [124])) [0 S8 A64])
        (reg/v:DI 129 [ wp0 ])) 320 {*movdi_internal64} (nil)
    (expr_list:REG_DEAD (reg/v:DI 129 [ wp0 ])
drivers/md/raid6int8.c:185: confused by earlier errors, bailing out
make[2]: *** [drivers/md/raid6int8.o] Error 1
make[1]: *** [drivers/md] Error 2
make: *** [drivers] Error 2
[root at kamitch-lnx linux-]# gcc --version
gcc (GCC) 3.4.4 20050721 (Yellow Dog 3.4.4-2.ydl.2)
Copyright (C) 2004 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO

Does any of this sound familiar to anyone... What kernel/config combo 
would be recommended for this smattering of Powermac machines?


More information about the Linuxppc64-dev mailing list