Xilinx Linux 2.6 for XPS LL_TEMAC and LL_FIFO problem

Mirek23 miroslaw.dach at psi.ch
Fri Jul 25 21:22:15 EST 2008

Hi John and Mike,

Thank you for your reply. We have modified out FPGA design and now we have
LL_TEMAC with LL_DMA component connected instead of the LL_FIFO. Before
building linux kernel we have tried to build the u-boot (downloaded from the
xilinx-git tree).

It was relatively easy to build u-boot which has the ll_temac with ll_dma

next we have tried to run u-boot on our ppc (virtex-4 FX12). All went fine
till the moment to establish the communication with the network.

I put some debug messages to the xilinx ll_dma and ll_temac drivers and we
have found that u-boot hangs 
during dma initialisation:

more specifically in the function calls :
       XLlDma_Initialize(XLlDma * InstancePtr, u32 BaseAddress) 
               XLlDma_Reset(XLlDma * InstancePtr) 

Do you have any idea what could be wrong with dma initialization?

Best Regards



View this message in context: http://www.nabble.com/Compile-time-error%2C-compiling-Xilinx-Linux-2.6-for-XPS-LLTEMAC-tp16065692p18649823.html
Sent from the linuxppc-embedded mailing list archive at Nabble.com.

More information about the Linuxppc-embedded mailing list