Xilinx Linux 2.6 for XPS LL_TEMAC and LL_FIFO problem

John Linn John.Linn at xilinx.com
Sat Jul 26 07:54:53 EST 2008

{resend as I forgot to send to the mailing list)

Hi Mirek,

Since this is a u-boot issue, we can move this conversation off this

The u-boot that is in the git repository has not been tested on the
Virtex4 platform.

I have only tested on the ML507, Virtex 5 platform.

There's not a ML403/ML405 board supported in our git tree, so I'm
curious what you did to try to build it for V4.

There are differences between V4 and V5 with the DMA as it's hard in V5
and hangs off the DCR bus of the processor.

The kernel itself is running on both the ML405 and the ML507, but not
yet with u-boot.


> -----Original Message-----
> From: linuxppc-embedded-bounces+john.linn=xilinx.com at ozlabs.org
> bounces+john.linn=xilinx.com at ozlabs.org] On Behalf Of Mirek23
> Sent: Friday, July 25, 2008 5:22 AM
> To: linuxppc-embedded at ozlabs.org
> Subject: RE: Xilinx Linux 2.6 for XPS LL_TEMAC and LL_FIFO problem
> Hi John and Mike,
> Thank you for your reply. We have modified out FPGA design and now we
> LL_TEMAC with LL_DMA component connected instead of the LL_FIFO.
> building linux kernel we have tried to build the u-boot (downloaded
from the
> xilinx-git tree).
> It was relatively easy to build u-boot which has the ll_temac with
> support.
> next we have tried to run u-boot on our ppc (virtex-4 FX12). All went
> till the moment to establish the communication with the network.
> I put some debug messages to the xilinx ll_dma and ll_temac drivers
and we
> have found that u-boot hangs
> during dma initialisation:
> more specifically in the function calls :
>        XLlDma_Initialize(XLlDma * InstancePtr, u32 BaseAddress)
>                XLlDma_Reset(XLlDma * InstancePtr)
>                          XLlDma_mBdRingSnapShotCurrBd(TxRingPtr);
> Do you have any idea what could be wrong with dma initialization?
> Best Regards
> Mirek
> --
> View this message in context:
> for-XPS-LLTEMAC-tp16065692p18649823.html
> Sent from the linuxppc-embedded mailing list archive at Nabble.com.
> _______________________________________________
> Linuxppc-embedded mailing list
> Linuxppc-embedded at ozlabs.org
> https://ozlabs.org/mailman/listinfo/linuxppc-embedded

This email and any attachments are intended for the sole use of the named recipient(s) and contain(s) confidential information that may be proprietary, privileged or copyrighted under applicable law. If you are not the intended recipient, do not read, copy, or forward this email message or any attachments. Delete this email message and any attachments immediately.

More information about the Linuxppc-embedded mailing list