Problem booting Linux 2.6 on Virtex-4

David Baird dhbaird at
Tue Jan 15 11:14:14 EST 2008

Hi Steve,

On Jan 14, 2008 2:09 PM, Stephen Neuendorffer
<stephen.neuendorffer at> wrote:
> What kernel version are you targeting? Are you using arch/powerpc or arch/ppc?  V4 has a data cache errata, which isn't currently in mainline arch/powerpc.

I am using arch/ppc/, but to be honest, I don't yet know what the
difference is between those two trees.

Also, I am still learning how to use git, but it appears that I am
using this version:

    Tags: v2.6.24-rc7

I am actually using OpenEmbedded which executes the following commands
to get the Linux tree:

     git clone git://
     cd linux-2.6
     git clone git://  master

>         if((mfpvr() & 0xfffff000) == 0x20011000) {
>             /* PPC errata 213: only for Virtex-4 FX */
>             __asm__("mfccr0  0\n\t"
>                     "oris    0,0,0x50000000 at h\n\t"
>                     "mtccr0  0"
>                     : : : "0");
>         }

I tried out this code snippit, but it did not help :-(  I also looked
in head.S and found that this was already in there:

    #if defined(CONFIG_XILINX_VIRTEX_4_FX)
      /* PPC errata 213: only for Virtex-4 FX */
      mfccr0  0
      oris    0,0,0x50000000 at h
      mtccr0  0

Today, I tried a completely fresh design in EDK 9.2i (whereas I had
been using 9.1i).  I tried the design found in
EDKexamples/  This design works :-)  I am
not sure why it works (or rather, why the other one did not work), but
it works.


(P.S. - Sorry I forgot to send to this to the list on the first try)

More information about the Linuxppc-embedded mailing list