Linux doesn not boot from u-boot on ML403

Miroslaw Dach miroslaw.dach at
Thu Aug 30 01:31:56 EST 2007

Hi Grant,

	Yes you are right that I should use uImage instead of zImage.elf

I have tried first bootm and uImage but it also hanged during 
uncompression so next I have tried bootelf zImage.elf to see how this 
works because I was able to run zImage.elf straight from EDK via jtag.



On Wed, 29 Aug 2007, Grant Likely wrote:

> On 8/29/07, Miroslaw Dach <miroslaw.dach at> wrote:
> > Hi Grant,
> >
> >         My zImage.elf has 1.1 MB and uImage 968 KB.
> > Could you tell me please how to hook up GDB to debug u-boot?
> Ah-HA!  You're using the wrong type of kernel image.  When booting
> from u-boot, you should be using a 'uImage', not a 'zImage.elf'.
> (generated with 'make uImage' in the kernel tree).  An you should use
> the 'bootm' command to boot the kernel.
> With bootm, u-boot can pass parameters to the kernel and it is u-boot
> that does the uncompression (instead of the zImage wrapper).
> Cheers,
> g.

          Miroslaw Dach (Miroslaw.Dach at - SLS/Controls Group 
                PSI - Paul Scherrer Institut CH-5232 Villigen

More information about the Linuxppc-embedded mailing list