USB flashdrive on Motorola MPC5200 (IceCube) board, linux ker nel 2.4.25 (DENX drop)

Furxhi, Orges Orges.Furxhi at
Sat Jul 29 07:57:11 EST 2006

Mr, Denk

>But if you tested so many devices, and none of them is working,  then
>this is probably an indication of another problem.

It might be, but I can not figure out what it is. I am hoping it is just a
kernel configuration mater.

>Do you have  a  chance  to  try  a  different  board?  Did  you  ever
>succesfully  use  *any*  USB  device  on your board? Maybe there is a
>hardware problem on your system.

I just have one icecube board (Lite5200 Ver 2.0), and I have 4 of our own
custom boards designed after the icecube. Right now I am testing on the
icecube board. I tried our boards but usb as mass storage is not working
there either.  

>Ummm... stupid question: is the green LED behind the USB connector on
>your board on or off?

There is one and it was off, I shorted out R164 and the led came on. Our
custom board takes care of this as well 

Which defconfig file should I use? 
I just tried the icecube_5200_CoralP_defconfig file but now the board is not
booting; it hangs right after this message:

"Uncompressing Kernel Image ... OK"



>Argh... your message is very difficult to read, as there is no difference
>between your text and mine.
I assumed that outlook would do it automatically, but apparently it did not,
sorry about that.  

>Also, please don't send separate mesages to the original  poster  and the
>mailing list; use Cc: instead.
I hit "reply" instead of "reply all" by mistake; sorry about that too, I
will not happen again.

More information about the Linuxppc-embedded mailing list