USB root filesytem using a 2.6 kernel?

Jeff Stevens jsteve17 at
Tue Sep 13 22:17:48 EST 2005

Has anyone had any luck booting from a linux filesytem
on a USB pen drive running 2.6?  I am running kernel
2.6.9 that is programmed into flash and am trying to
boot from a root filesystem on a USB pen drive.  I am
using the kernel command line option "root=/dev/sda1".
 I am able to NFS boot my system, and then mount my
pen drive, and can see all of the files fine. 
However, it tells me that I have an invalid root
option if I try setting root to /dev/sda1.  I
understand under 2.4 there is a patch that keeps
trying to mount the sda1 device with time delays in
between each try.  I tried that, but it didn't help. 
I also tried the 2.6 patch that keeps a list of ready
devices, and that didn't work.  I was trying to do
this without a ramdisk, but so far it looks like I'll
have to use one after all.

   Jeff Stevens
   jsteve17 at

Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 

More information about the Linuxppc-embedded mailing list