Data TLB error exception

Damjan Lampret damjan.lampret at
Sat Mar 18 03:53:15 EST 2000

----- Original Message -----
From: Wolfgang Denk <wd at>
To: Damjan Lampret <damjan.lampret at>
Sent: Tuesday, February 29, 2000 7:27 PM
Subject: Re: Data TLB error exception

> > I suspect there is something wrong with my hub (MBX is connected to a
> Try a cross-over cable first - then you can be  sure  which  part  is
> failing.
> Wolfgang Denk

Perhaps this will save someone a couple of days of troubles...

Once in a while strange things happen. I have PINE Technology's 8-port
ethernet hub that works ok. Hub like any other. I have various custom MPC8xx
boards and PCs connected to it. Everything works OK. So I connected MBX860
to it and tried to download linux via tftp. My MBX was complaining with
'Network Error 0019' or something like that. I disconnected everything
except MBX and my working PC. It didn't work. Lost a couple of weeks trying
to figure out what is wrong. Lately I got another hub. This one is 8-port
3com's Office Connect. Since then MBX860 works great. And don't tell me to
check my cables or something like that. I tried everything except another

regards, Damjan

PS GCC from Dan's mbxroot.tar.gz is not working properly on my MBX. Other
simple programs from /bin and /usr/bin etc work except GCC which hangs
console (it outputs proper MPC8xx assembly in /tmp and then stops; kernel is
still running properly). I tried several GCCs from Dan's mbxroot package. Is
any of them properly compiled for native work on Linux/MPC860 (I found gcc
in several places) ? I have also compiled egcs-2.90.25 for cross work on
Linux/i386 but binaries segfault on Linux/MBX. Assembly is properly
generated by I suspect that not proper crt* are linked to final binary.

** Sent via the linuxppc-embedded mail list. See

More information about the Linuxppc-embedded mailing list