[PATCH 00/13] Refactor pci_is_brdige() to simplify code
Yijing Wang
wangyijing at huawei.com
Sat Apr 26 12:49:24 EST 2014
On 2014/4/25 17:42, David Laight wrote:
> From: Yijing Wang
>> This patchset rename the current pci_is_bridge() to pci_has_subordinate(),
>> and introduce a new pci_is_bridge() which determine pci bridge by check
>> dev->hdr_type. The new one is more accurate. PCIe Spec define the pci
>> device is a bridge by the dev->hdr_type = 0x01 || 0x02.
>
> That is a dangerous rename and is likely to cause difficult to
Hi David,
I renamed pci_is_bridge() to pci_has_subordinate() because
static inline bool pci_is_bridge(struct pci_dev *pci_dev)
{
return !!(pci_dev->subordinate);
}
which always check dev->subordinate.
> identify bugs in any code you've missed.
What are you referring to ?
Thanks!
Yijing.
>
> David
>
> �{.n�+�������+%��lzwm��b�맲��r��zX���w��{ay�ʇڙ�,j��f���h���z��w������j:+v���w�j�m��������zZ+�����ݢj"��!�iO��z��v�^�m����nƊ��Y&�
>
--
Thanks!
Yijing
More information about the Linuxppc-dev
mailing list