[PATCH 00/13] Refactor pci_is_brdige() to simplify code

David Laight David.Laight at ACULAB.COM
Fri Apr 25 19:42:45 EST 2014

From: Yijing Wang
> This patchset rename the current pci_is_bridge() to pci_has_subordinate(),
> and introduce a new pci_is_bridge() which determine pci bridge by check
> dev->hdr_type. The new one is more accurate. PCIe Spec define the pci
> device is a bridge by the dev->hdr_type = 0x01 || 0x02.

That is a dangerous rename and is likely to cause difficult to
identify bugs in any code you've missed.


More information about the Linuxppc-dev mailing list