[PATCH 1/4 v4] POWERPC: Add _nmask_and_or_msr() declartion to asm-powerpc/system.h

Paul Mackerras paulus at samba.org
Thu Jan 24 14:44:29 EST 2008

Jon Loeliger writes:

> +extern void _nmask_and_or_msr(unsigned long nmask, unsigned long or_val);

Hmmm, I wish someone would think of a better name for it.  In fact I
have tended to avoid using it, and instead done things like

	mtmsr((mfmsr() & ~x) | y);

where necessary instead.


More information about the Linuxppc-dev mailing list