[PATCH 1/3] 8xx: Analogue & Micro Adder875 board support.

Bryan O'Donoghue bodonoghue at codehermit.ie
Mon Jan 14 01:26:12 EST 2008

Greetings Scott.

Using u-boot Adder_config 

U-Boot 1.3.1-g5c740711-dirty (Jan 13 2008 - 13:43:30) - using an ELDK
4.1 uclibc toolchain

I can't boot your board - port.

I've applied your code against Linus' git v2.6.26-rc7 as at today.
I have to apply 

diff --git a/arch/powerpc/boot/wrapper b/arch/powerpc/boot/wrapper
index 31147a0..8c060ca 100755
--- a/arch/powerpc/boot/wrapper
+++ b/arch/powerpc/boot/wrapper
@@ -163,7 +163,7 @@ ps3)
     platformo="$object/fixed-head.o $object/$platform.o"


diff --git a/arch/powerpc/boot/Makefile b/arch/powerpc/boot/Makefile
index 18e3271..e426052 100644
--- a/arch/powerpc/boot/Makefile
+++ b/arch/powerpc/boot/Makefile
@@ -56,7 +56,7 @@ src-plat := of.c cuboot-52xx.c cuboot-83xx.c
cuboot-85xx.c holly.c \
                cuboot-ebony.c treeboot-ebony.c prpmc2800.c \
                ps3-head.S ps3-hvcall.S ps3.c treeboot-bamboo.c
cuboot-8xx.c \
                cuboot-pq2.c cuboot-sequoia.c treeboot-walnut.c
cuboot-bamboo.c \
-               fixed-head.S ep88xc.c cuboot-hpc2.c
+               fixed-head.S ep88xc.c cuboot-hpc2.c redboot-8xx.c 
 src-boot := $(src-wlib) $(src-plat) empty.c

manually since those two fail to apply to Linus' tree - presumably
because they depend on other patches - should I be using -mm or some
other tree here instead ?

I then run

source /opt/eldk/eldk_init ppc_8xx

export ARCH=powerpc

make adder87x-uboot_defconfig

make uImage

cp arch/powerpc/boot/uImage /tftpboot - which is my tftpd root

In U-Boot then.

=> tftpboot 0x400000 uImage
=> bootm 0x400000

Which doesn't boot.

Attaching a BDI2000 to the target board I see that the kernel is
panicing somewhere around line 104 of arch/powerpc/kernel/prom.c in
of_scan_flat_dt - presumably because the kernel cannot find an
OpenFirmware tree..

I admit not understanding everything I should about where the output
of .dts & dtc "go" with respect to booting Linux.... but, didn't want to
ask on the list - lest I display a "lack of knowledge" ...

Seriously though, could you offer a pointer as to how I run this code on
the Adder875 here ?

My kernel command line is

root=/dev/nfs nfsroot= rw
ip= console=ttyCPM,115200

I've also tried - in ignorance of how OF works I admit to add the
following options to u-boot to no avail.

/* pass open firmware flat tree */
#define CONFIG_OF_LIBFDT      1
#define CONFIG_OF_HAS_BD_T    1
#define CONFIG_OF_HAS_UBOOT_ENV       1

#define OF_CPU                        "PowerPC,875 at 0"
#define OF_SOC                        "soc875 at ff000000"
#define OF_TBCLK              (bd->bi_busfreq / 4)

Have I missed a step with the .dts & dtc - and is this why
of_scan_flat_dt is failing - or - should the board port simply "just
work" with a 

make dder87x-uboot_defconfig && make uImage ?

I'm sure I've done something obscenely obvious with respect to not
getting the whole OF thing right.... but if you could point to what that
is... I'd be highly appreciative.


More information about the Linuxppc-dev mailing list