[PATCH] Start arch/powerpc/boot code reorganization

Segher Boessenkool segher at kernel.crashing.org
Thu Sep 21 10:07:05 EST 2006

>>> So please comment the nastiness with a big "HACK HACK HACK"  
>>> comment and
>>> make sure it only ever gets used on systems where nothing better is
>>> available, and all should be fine.
>> An option is to call it something like fw,address to avoid  
>> confusion and
>> make it somewhat clearer that it's really a firmware address useable
>> within the context of the firmware...
> Okay.  We did talk about that but then we realized that "address"
> was for vaddrs.  We thought of other names like "bootwrapper-vaddr"
> etc. but "fw,address" or "fw,vaddr" are probably better--they show  
> that
> the vaddr was setup by the fw.

If you use a different name than "address", you're not bound to its
semantics either.  And as those semantics have some problems, please
do change-em.  How about:

The "reg-virtual-address" property contains the same regions as the
"reg" property, in the same order; each entry is #address-cells from
the root node 32-bit integers wide(*); the entry describes a
contiguous area of virtual memory of the same size as the
corresponding "reg" entry, mapping that area, or 0 if the area isn't

Any holes in this definition?


(*)  This isn't strictly correct, but OF doesn't describe the size of
virtual addresses anywhere.  In practice, it's the same as the size
of physical addresses always.  Oh, and the name "virtual" isn't correct
in PowerPC-speak anyway, heh.

More information about the Linuxppc-dev mailing list