[PATCH] Start arch/powerpc/boot code reorganization

Matt Porter mporter at embeddedalley.com
Thu Sep 21 23:37:07 EST 2006

On Thu, Sep 21, 2006 at 02:07:05AM +0200, Segher Boessenkool wrote:
> If you use a different name than "address", you're not bound to its
> semantics either.  And as those semantics have some problems, please
> do change-em.  How about:
> The "reg-virtual-address" property contains the same regions as the
> "reg" property, in the same order; each entry is #address-cells from
> the root node 32-bit integers wide(*); the entry describes a
> contiguous area of virtual memory of the same size as the
> corresponding "reg" entry, mapping that area, or 0 if the area isn't
> mapped.
> Any holes in this definition?

On PPC44x (and other PowerPC processors) the number of address cells
to represent a virtual address and a physical address differ due the
36-bits of physical address space. Regardless of the name of the
new property, it should be defined to allow a different number of
address cells to represent an address in virtual address space.
> (*)  This isn't strictly correct, but OF doesn't describe the size of
> virtual addresses anywhere.  In practice, it's the same as the size
> of physical addresses always.  Oh, and the name "virtual" isn't correct
> in PowerPC-speak anyway, heh.

Actually, in practice, it's not always the same size as a physical
address. We have 36-bit physical addressing systems in the real world.

FWIW, I'd be happy with this property name or fw,address. When we
discussed this on IRC the thought was to conform to what already
existed for this purpose in the OF spec. Since the address prop sounds
like it will confuse some people I think it makes sense to add a
new property (might as well just throw out the spec :P).


More information about the Linuxppc-dev mailing list