Floppy problems

David A. Gatwood dgatwood at deepspace.mklinux.org
Sat Nov 20 17:17:00 EST 1999

On Sat, 20 Nov 1999, Eric Dorland wrote:

> I've tried a bunch of different floppies (at least 5), all give the exactly
> same error. The drive works flawlessly in the MacOS. I don't really have
> MkLinux installed to test it. Something I forgot to mention. When I try to
> to do dd, it gives the error and hangs the terminal. I can switch to another
> virt. console, but the dd process refuses to die. Is there something odd
> about the G3 floppy drive? Does anyone have this problem?

It does sound like a driver bug.  And no, the G3 machines should be using
the same (Mitsubishi or Panasonic) mechanisms used in all the other
PowerMacs.  It's remotely possible they used the Sony mechanism, but I
don't think they've done that since the Quadras, so....

> BTW, is there any utility in the MacOS to write raw disk images? DiskCopy
> will mount them, but doesn't seem to want to write them to a floppy. (Its a
> Debian i386 bootdisk).

DiskCopy should be able to write them, too.


** Sent via the linuxppc-dev mail list. See http://lists.linuxppc.org/

More information about the Linuxppc-dev mailing list