Floppy problems

Eric Dorland dorland at lords.com
Sat Nov 20 16:53:42 EST 1999

On Fri, Nov 19, 1999 at 07:45:57PM -0800, David A. Gatwood wrote:
> On Fri, 19 Nov 1999, Hollis R Blanchard wrote:
> > On Fri, 19 Nov 1999, Eric Dorland wrote:
> > > 
> > > There seems to be a problem with the SWIM3 controller on my PowerMac G3.
> > > Whenever I try to do any floppy realted operation (mount, dd, whatever) it
> > > gives me this error:
> > > 
> > > end_request: I/O error, dev 02:00 (floppy), sector 36
> > > 
> > > does anyone know what this means or has had similar problems?
> > > 
> > > I'm running R5 on a a kernel I compiled myself, but not with anything
> > > outrageous, just a few patches. I've got a G3/266, and I'm running linux off
> > > a internal scsi drive.
> > 
> > Are you *positive* your floppy's good? Have you tried others?
> Does sound like a bad block, yeah.  If it happens for several disks that
> way, and if your drive works right in MacOS, you might see if MkLinux can
> read it.  If MkLinux's floppy code reads it and LinuxPPC's doesn't, it's a
> bug in the driver.  If, on the other hand, MkLinux's floppy driver fails
> as well, you'll probably get more debugging messages than you could ever
> possibly want....

I've tried a bunch of different floppies (at least 5), all give the exactly
same error. The drive works flawlessly in the MacOS. I don't really have
MkLinux installed to test it. Something I forgot to mention. When I try to
to do dd, it gives the error and hangs the terminal. I can switch to another
virt. console, but the dd process refuses to die. Is there something odd
about the G3 floppy drive? Does anyone have this problem?

BTW, is there any utility in the MacOS to write raw disk images? DiskCopy
will mount them, but doesn't seem to want to write them to a floppy. (Its a
Debian i386 bootdisk).

Eric Dorland
dorland at lords.com

** Sent via the linuxppc-dev mail list. See http://lists.linuxppc.org/

More information about the Linuxppc-dev mailing list