Installing Ubuntu on an XServe

Paul Nasrat pnasrat at
Sat Jun 2 19:48:43 EST 2007

On Fri, 2007-06-01 at 20:48 -0400, Todd O'Bryan wrote:
> I've been trying unsuccessfully to install Ubuntu on a G4 XServe with
> two removable drives for the past two days.
> I get as far as it trying to install yaboot and get an error saying that
> ofpath doesn't support the driver for pata_pdc2027x. I tried poking
> around in the Open Firmware to see if I could figure out what it should
> be, but had no luck. I'm a little worried that Linux may think the
> drives are SCSI but OF thinks they're SATA--but I'm also not sure what
> difference that might make.

What kernel are you running?

Can you tar up /proc/device-tree and put it on a web page for me to
download. Then I'll try modify ofpath to figure out.

> Another wrinkle that I should mention is that the version of parted
> included with the Ubuntu install CD (I've tried using both alternate and
> server versions) seems to have some problems. I could never get it to
> set up the drives as a software RAID array and today, after dropping
> into the shell and trying to run parted manually, I got a message saying
> "You've found a bug in parted" which was promptly followed by a core
> dump.

David - any ideas on the parted issue.  What version of parted is it you
are using?


More information about the Yaboot-users mailing list