[SLOF] [PATCH 1/2] Move archsupport.fs into board-qemu directory

Thomas Huth thuth at redhat.com
Mon Jan 4 20:17:25 AEDT 2016

On 23.12.2015 02:43, Alexey Kardashevskiy wrote:
> On 12/22/2015 07:25 AM, Thomas Huth wrote:
>> The "hv-cas" hypercall is only available on board-qemu.
>> Including archsupport.fs on board-js2x breaks the boot
>> process there. Thus the archsupport.fs file should
>> reside in the board-qemu/slof directory instead and
>> only be included from there.
> Thanks, applied.
> Does js2x boot now? :)

Unfortunately not yet, there are a couple of problems left:

- dma-alloc & dma-map-in and friends do not work yet, causing the
  libusb code to abort when trying to allocate memory
  => I have a patch for this pretty much ready, will send it later

- But even with the dma-alloc fixed, the new libusb code does not seem
  to work right with real hardware yet, I get messages about STALLs and
  timeouts when I connect an USB device

- The biosemu seems currently to be broken, it simply hangs when trying
  to init the graphics card of my PowerStation

- I haven't tried network booting yet, but I guess it will also need
  some love since there have has been a major change in this area
  during the last years, and I guess nobody tried the bcm driver since
  that point in time yet.

I unfortunately do not have much spare time to work on these issues, and
flashing new version on the PowerStation is quite time consuming when it
breaks the boot afterwards (you have to switch to the permanent side to
restore it...), so additional help would be very welcome if somebody
still can run SLOF on a js2x machine!


More information about the SLOF mailing list