[Skiboot] [PATCH] libstb: Pass a tpm_dev to tpm_i2c_request_send()

Stewart Smith stewart at linux.ibm.com
Fri Nov 9 16:53:21 AEDT 2018

"Oliver O'Halloran" <oohall at gmail.com> writes:
> Just pass the container structure rather than bus_id and xscom_base to
> tpm_i2c_request_send(). Rename xscom_base to i2c_addr while we're here
> since that's just plain wrong.
> Signed-off-by: Oliver O'Halloran <oohall at gmail.com>

Looks good and sensible. Merged to masetr as of 324365f3aa9bcd55048f3ae7b77d5dff8658a8de

Stewart Smith
OPAL Architect, IBM.

More information about the Skiboot mailing list