[Skiboot] [PATCH 09/13] xive: Add some dump facility

Benjamin Herrenschmidt benh at kernel.crashing.org
Thu Feb 2 18:18:56 AEDT 2017

On Thu, 2017-02-02 at 17:52 +1100, Stewart Smith wrote:
> OPAL_XIVE_SYNC? I don't seem to see a definition or implementation
> anywhere.

It's coming :-) You can keep that reserved if you want.

> > +#define OPAL_XIVE_DUMP                               142
> In order to avoid confustion with the various DUMP calls, what about a
> naming convention of OPAL_foo_DEBUG_DUMP ?


> > +#define OPAL_LAST                            142
> This patch will also conflict with the several reserved IDs I put in for
> XIVE... probably simple fixup, but a rebase could be good?

I can do that tmr I suppose.. I dont have that specific branch at hand
though :-)

And yes, the reserved were for this (and a couple more yet to come).


More information about the Skiboot mailing list