[Skiboot] [RFC PATCH 1/4] ibm-fsp/firenze: uncore header file definitions
maddy at linux.vnet.ibm.com
Thu Apr 23 12:49:07 AEST 2015
On Wednesday 22 April 2015 07:27 AM, Michael Ellerman wrote:
> On Wed, 2015-04-22 at 11:44 +1000, Stewart Smith wrote:
>> Madhavan Srinivasan <maddy at linux.vnet.ibm.com> writes:
>>> + * Power8 has Nest Instrumentation support with which per-chip
>>> + * utilisation metrics like memory bandwidth, IO bandwidth and
>>> + * many other component metrics can be obtained. These Nest
>>> + * counters can be programmed via scoms or HW PORE Engine,
>>> + * called PORE_SLW_IMA.
>>> + *
>>> + * In the Linux kernel side, have used intel's "uncore" framework
>>> + * to plug the Power8 nest instrumentation support. For the
>>> + * consistency, have used "uncore" for in the variable/file names
>>> + * here for services provided by opal.
>>> + *
>> Why not just call it nest_pmu everywhere? I can't see anywhere that's
>> really forcing us to use uncore terminology.
> I'm not entirely convinced it makes sense to use the uncore stuff in Linux, but
> it definitely doesn't make sense to propagate the name down into skiboot.
The latest update is that, we have a new draft catalog lid released.
Based on that, I am developing feature detection code. I will also make
Thanks for review
More information about the Skiboot