[PATCH v2] docker: update dependency for current build

Lukas Bulwahn lukas.bulwahn at gmail.com
Mon Feb 17 23:54:46 AEDT 2020

On Mon, 17 Feb 2020, Daniel Axtens wrote:

> >
> > There seems to be a conflict with different versions of libssl and
> > libmysqlclient that did not exist previously with Ubuntu 18.04.
> Huh, I rebuilt my image a few weeks ago and didn't see this.
> So I tried this:
> docker-compose down
> docker rmi patchwork_web:latest
> docker-compose build --no-cache web
> Then I was able to reproduce the problem. I think it was being masked by
> the cache on my end, but I can't find a change that would have
> introduced it. Commit a0db4732139d ("docker: Use pyenv for Python
> versions") looks like it introduced the dependency, but clearly it
> worked then, and we haven't changed the base image or the other packages
> we install! It is weird that it would have broken under us like this. 

Yes, I have hit that problem with docker as well.
Docker caches, Debian/Ubuntu distro updates and project-specific changes 
makes it impossible to figure out why it "just works on my machine", and 
never on those of the others ;)

I guess here is no easy answer, though, and it works for the moment.


More information about the Patchwork mailing list