[PATCH linux dev-4.7] arm: configs: aspeed: Disable CONFIG_MTD_SPI_NOR_USE_4K_SECTORS

Cédric Le Goater clg at kaod.org
Sun May 14 06:49:55 AEST 2017

On 05/11/2017 02:12 PM, Joel Stanley wrote:
> On Thu, May 11, 2017 at 7:31 AM, Adriana Kobylak
> <anoo at linux.vnet.ibm.com> wrote:
>> Milton stopped by and mentioned that you had tried to modify the 4K erase
>> sector previously for a perhaps bmc chip and saw some flash corruption when
>> moving to an image that changed it?
>> Just wanted to add that this change only changes the pnor setting and I
>> didn’t see any issues powering on a system after updating the BMC with an
>> image with this change. Then I updated the pnor with an image that had the
>> mbox enabled. Also checked with AndrewJ and the hostboot team and there’s no
>> hard-coded assumptions in their side about the erase size.
>> With all this info let me know if you have any thoughts or concerns.
> I recall issues relating to this option. I didn't record what they were 
> though.

We tried to activate 4K erase on some chips, which supported it, 
and that the OpenPOWER systems use. That was because the PNOR 
sections were not aligned with the erase size and that caused 
some issues in pflash. But it breaks the compatibility with 
previously created jffs2 filesystems. jffs2 stores the erase 
size. So we stepped back.

> Cedric, can you remind me what the issues are with the 4K kconfig option?

CONFIG_MTD_SPI_NOR_USE_4K_SECTORS enables the 4K erase commands, 
and without it, the driver will use the sector erase command, most
likely 64K. I suppose we could have the same problem as described 
above, as it can change the default erase size of a chip. to be



More information about the openbmc mailing list