[PATCH qemu 17/38] aspeed/smc: unfold the AspeedSMCController array

Joel Stanley joel at jms.id.au
Mon Nov 21 18:26:46 AEDT 2016


On Sat, Nov 19, 2016 at 12:51 AM, Cédric Le Goater <clg at kaod.org> wrote:
> This is getting difficult to read. Also add a 'has_dma' field for each
> controller type.
>
> Signed-off-by: Cédric Le Goater <clg at kaod.org>

Reviewd-by: Joel Stanley <joel at jms.id.au>

> ---
>  hw/ssi/aspeed_smc.c         | 91 ++++++++++++++++++++++++++++++++++++---------
>  include/hw/ssi/aspeed_smc.h |  1 +
>  2 files changed, 74 insertions(+), 18 deletions(-)
>
> diff --git a/hw/ssi/aspeed_smc.c b/hw/ssi/aspeed_smc.c
> index eec087199a22..8e7e3bd9e335 100644
> --- a/hw/ssi/aspeed_smc.c
> +++ b/hw/ssi/aspeed_smc.c
> @@ -184,24 +184,79 @@ static const AspeedSegments aspeed_segments_ast2500_spi2[] = {
>  };

> +        .name              = "aspeed.smc.spi",
> +        .r_conf            = R_SPI_CONF,
> +        .r_ce_ctrl         = 0xff,

What does 0xff mean in this context? Should we have a #define for this?

> +        .r_ctrl0           = R_SPI_CTRL0,
> +        .r_timings         = R_SPI_TIMINGS,


More information about the openbmc mailing list