[PATCH] iommu fixes, round 2
johnrose at austin.ibm.com
Thu Oct 28 09:25:47 EST 2004
On Wed, 2004-10-27 at 18:08, Paul Mackerras wrote:
> John Rose writes:
> > Thirdly, iommu_devnode_init() also has an iSeries implementation, so
> > it's not pSeries-specific. No need to rename it, as suggested in the
> > comment.
> I would rather we didn't have two functions with the same name, as we
> do for iommu_devnode_init (with iSeries and pSeries implementations),
> because that is one more obstacle to eventually making a single kernel
> binary that can run on iSeries and on other machines. That goal is
> still some distance off but we shouldn't make it harder to reach if
> possible. That's the motivation for having a function pointer in
> ppc_md for it.
Good point. To contradict my earlier statement, let's rename them :)
None of the other functions in [i,p]Series_iommu.c share names. The two
implementations are called from i and p-specific locations anyway, so
renaming won't be a problem.
Will post a patch tmw.
More information about the Linuxppc64-dev