[PATCH] iommu fixes, round 2

Paul Mackerras paulus at samba.org
Thu Oct 28 09:08:17 EST 2004

John Rose writes:

> Thirdly, iommu_devnode_init() also has an iSeries implementation, so
> it's not pSeries-specific.  No need to rename it, as suggested in the
> comment.

I would rather we didn't have two functions with the same name, as we
do for iommu_devnode_init (with iSeries and pSeries implementations),
because that is one more obstacle to eventually making a single kernel
binary that can run on iSeries and on other machines.  That goal is
still some distance off but we shouldn't make it harder to reach if
possible.  That's the motivation for having a function pointer in
ppc_md for it.


More information about the Linuxppc64-dev mailing list