Linux on G5 Xserve?

Greg Johnson gjohnson at
Sat May 15 01:56:07 EST 2004

On Fri, May 14, 2004 at 10:38:28AM -0500, Derek.Fults at wrote:
> Greg,
>   I've tried your patch and config file on the 2.6.6 kernel sources, but
> still no joy.  I still don't see anything after 'returning from
> prom_init"
> I was hoping I could gather some information about you environment if
> you don't mind.

Sure, no problem.

> I'm using yaboot 1.3.11, I'm able to load a kernel using the command,
> enet:,vmlinux, but it fails when trying to load a yaboot.conf file.  I
> was curious if you're seeing this as well.

I'm using yaboot 1.3.12 which I hacked a bit.  Out of the box it won't
load the config file.  I changed line 1505 in second/yaboot.c from

useconf = load_config_file(, boot.file, boot.part);


useconf = load_config_file("enet:", "", 0);

to get it to load the config file.  Yaboot is incorectly parsing the
device path/partition which can be seen by turning on debugging.

> Can you tell me what version of binutils and compiler you're using?

I am cross compiling a 64 bit kernel on a 32 bit ppc machine.  I built a
cross-toolchain from the debian toolchain-source package.  I'm not sure
what patches debian includes.  The versions are:

powerpc64-linux-gcc (GCC) 3.3.3 (Debian 20040321)
GNU ld version 20031029 Debian GNU/Linux

> Have you changed any environment variables in OF to scca?

Yeah, I changed all the input and output's to scca.  I'm not sure if
this mattered.

> Is there anything else that could be different that I'm forgetting?

I don't know.  Sounds like our setups are pretty similar.  I'm
netbooting like you.  Make sure you pass "console=ttyS0" on the command
line.  SMP is broken at the moment, so also use "nosmp" if you build an
SMP kernel.

I'll send you my kernel off-list.  Yaboot shouldn't make too much
difference, except for the config file loading.


** Sent via the linuxppc64-dev mail list. See

More information about the Linuxppc64-dev mailing list