latest toolchain in binary format?

Steve Munroe sjmunroe at
Tue Sep 23 05:59:38 EST 2003

mjstumpf writes:

> Just tried it.  Still no dice; compiling that way, using SLES 8 + 64 bit
> dev kit still results in a bogus error:
> lssbfrec.o: In function `lssbfrec':
> lssbfrec.c:21: undefined reference to `.LCTOC0'
> collect2: ld returned 1 exit status

This is not the usual symptom for TOC overflow. I would expect something

auxl.o(.text+0xdbfa): relocation truncated to fit: R_PPC64_TOC16_DS

Your error implies that a single object/compile unit is so large it can't
be compiled...


 objdump -h *.o | grep '\.toc'

and add up all the numbers (in hex) from the 3rd column.

You may have to break this application into a number of shared libraries
(each *.so has its own 64KB TOC). So it would be good to know how close or
far you are from fitting. Also some applications try to prelink all
objects into a single large object and try to build the application from
that. This will not work in your case. And don't even think about linking

Also I have to ask all the obvious questions like: Is this gcc or xlc?
This xlf or g77?

** Sent via the linuxppc64-dev mail list. See

More information about the Linuxppc64-dev mailing list