Kernel panic on a p630

Nathan Lynch nathanl at
Mon Sep 22 16:40:10 EST 2003

Hi Anton-

> The symbios controller is currently checking the return value of
> pci_set_mwi. Short term fix is below. As Paul suggested we need a way in
> the arch_prepare_mwi code to differentiate between a failure and
> everything is good, no need to set the cacheline/mwi bits.

I have tried the workaround (with test5 from ameslab, default config),
and still get the "cannot mount root fs" problem.  I believe the symbios
controller is somehow escaping detection altogether, because I do not
even see the driver initialization messages during bootup, e.g. from a
test3 kernel:

sym.65.1.0: setting PCI_COMMAND_INVALIDATE.
sym0: <1010-66> rev 0x1 on pci bus 65 device 1 function 0 irq 325
sym0: No NVRAM, ID 7, Fast-80, LVD, parity checking
sym0: SCSI BUS has been reset.

These messages do not appear with test5 whether the patch is applied or not.

I booted with initcall_debug, and it looks like sym2_init is called.  I
added a printk to sym2_probe, and that did not show up in the boot messages.

I can see how the pci_set_mwi situation would break things, but I am not
convinced the symbios code is even getting to that point.  Is there
another issue at play here, or am I missing something?


** Sent via the linuxppc64-dev mail list. See

More information about the Linuxppc64-dev mailing list