[RFC][PATCH] discontiguous vterms

Hollis Blanchard hollisb at us.ibm.com
Sat Nov 1 03:24:10 EST 2003

Hey Olof, thanks for the comments...

On Thursday, Oct 30, 2003, at 21:26 US/Central, Olof Johansson wrote:
> hvc_get_vterms():   "u32 array[]" will never really be an array: array
> arguments always get casted to pointers instead. Defining it as one
> would be less misleading (u32 *array).

Personally I think it would be more misleading. u32 *array is a pointer
to a u32 (variable name aside). u32 array[] is a pointer to a whole
array of u32's. Obviously there's no functional difference, but...

> hvc_console_setup(): How about a variable that the return value from
> hvc_get_vterms() is saved in and compared to instead? Makes it a
> little more readable.


> Other cleanup: There's a struct called hvc_struct, and an
> instantiation of the same struct called hvc_struct. Maybe the
> instantiation should be renamed to "hvcs" or something similar?

Agreed. I've noticed it, but wanted to stick with functional changes
for now.

> Also, one final suggestion: Right now there's hvc_* functions both in
> pSeries_lpar.c and hvc.c. Would it be better to split the namespace to
> be vterm_* or vty_* in pSeries_lpar instead? This would also make a
> distinction between the hvc driver and the vterm hypervisor interface.
> vterm_get_vterms() would obviously need to be renamed. :)

Yup, it would be a good distinction to make. I'll think about the
naming... :)

Hollis Blanchard
IBM Linux Technology Center

** Sent via the linuxppc64-dev mail list. See http://lists.linuxppc.org/

More information about the Linuxppc64-dev mailing list