2.5 kernel on Power3

Gary Byers gb at clozure.com
Tue Apr 29 04:00:20 EST 2003

On 28 Apr 2003, Todd Inglett wrote:

> On Sat, 2003-04-26 at 19:27, Gary Byers wrote:
> > Hi.
> >
> > I've been trying for some time (off and on ...) to build a working
> > 2.5 kernel for a Power3 system (a dual-processor 43P/260).  I've
> > been compiling with an up-to-date CVS+patches GCC 3.3, and have tried
> > using both the 2.5.66 source from kernel.org and the bk treee from
> > source.scl.amselab.gov.
> Hmm...the ameslab tree should work.  At least I always test it on my
> 2-way 44P/270 which is very similar to your 260.

That's good to know; thanks.

Since I'm just fishing: do you compile the kernel with GCC 3.3, and
do you accept the default configuration ?

> [...]
> > The generated kernels all hang at the same point (the last message
> > is "returning from prom_init").  I've tried pulling the video
> > card (a repackaged Matrox Mystique, or something like it) and the
> > only difference is that the "returning from prom_init" message is
> > diverted to a serial console.
> Eliminating the video adapter was a good move.  The console should now
> go to ttyS0, but you can force it with console=ttyS0 anyway (this
> shouldn't be needed).

I tried an explicit "console=ttyS0" with the video card unplugged; the
exact output is:

instantiating rtas at 0x000000001ffd7000... done
starting cpu /cpus/PowerPC,POWER3 at 2... ok
opened /pci at fef00000
open success
opened /pci at fee00000
open success
 (translate ok) returning from prom_init

and then ... silence.  I tried pinging the machine several minutes
after this, just in case it had somehow booted but was having
difficulty telling anyone.  No luck.

> Do you see anything at all on the LEDs?

The front panel says "E105"; I -think- that that means something like
"control transferred to the OS."

> It might be as simple as having
> the serial cable attached to ttyS1.  I'm pretty sure the 260 has two
> serial ports.

It does.  The cable's connected to a PC running a terminal emulator at
9600/N/8/1, and it works fine as ttyS0 when I boot under a 2.4 kernel.

> The next message out should be "Starting Linux PPC64 <version>..." and
> it is forced to go out ttyS0.

My understanding is that there's a lot that could go wrong right after
the return from prom_init(): the kernel relocates itself in memory,
the MMU's enabled, stacks are initialized, etc.  I suppose that there's
also stuff that could go wrong in prom_init() itself, if it somehow
garbles information that later stages depend on.

Assuming that there's nothing in the default ppc64 configuration that's
inappropriate and given the fact that this is known to run on your
system, it seems reasonable to be suspicious of GCC 3.3.  I'll try to
build a GCC 3.2 and see if that's a factor.

> --
> Todd Inglett <tinglett at vnet.ibm.com>


Gary Byers
gb at clozure.com

** Sent via the linuxppc64-dev mail list. See http://lists.linuxppc.org/

More information about the Linuxppc64-dev mailing list