ml310 kernel2.6 booting problems

Grant Likely grant.likely at
Thu Jan 17 07:30:49 EST 2008

On 1/16/08, Joachim Meyer <Jogi95 at> wrote:
> Thx for the answer
> It's right, there is no /dev/console, but the MontaVista-Linux-kernel can fully boot with this rootFS, how comes?

hmmm, I don't know.  The montavista kernel might be running a
different binary as the init process.  Compare the kernel parameter
lines between the two.

> Doesn't matter, I was going to make my own RootFS anyway, so can you give me an hint how I would
> do this best?
> I tried the Klingauf-Script ( with busybox, but I still have no console in my /dev/ and it doesn't work.

Creating a console device is easy:

$ mknod /dev/console c 5 1

> I tried out buildroot, but I was a little overstrained with the configuration and when I did "make" it aborted with an error message
> after a long time of working
> Then I tried ELDK. I read that I could use the Directory "<install-dir>/ppc_4xx/" as rootfs but when I go there and look inside
> /dev I find only one entry:
> prw------- 1 jogi jogi 0 2007-01-20 04:58 initctl
> So this won't work, would it?

Looks like you haven't installed ELDK correctly.  I recommend
rereading the instructions and giving it another try.  ELDK is a great
starting point.

> Which way would be the best for me to get an good RootFS easily?
> If the answer would be buildroot can you give me a short summary which settings are importent?

Personally, I use buildroot, but you should start with ELDK to get things going.


Grant Likely, B.Sc., P.Eng.
Secret Lab Technologies Ltd.

More information about the Linuxppc-embedded mailing list