File system problem

mojtaba kernelppc at
Fri Jan 4 22:57:36 EST 2008

Thank you all for your helps.

Today I tried to make the file system again using buildroot. This time I
included busybox to the packages for target system (Before that, I did not
include the busybox). Surprisingly the system boot correctly.

But, I do not want to use busybox. I already compiled coreutiles and I want
to put them on my target system. After building the root file system I tried
to replace those symbolic links to busybox(such as ls, cp, ...) with the
real commands from coreutiles but I got this error.

Freeing unused kernel memory: 76k init
missing file opeKernel panic - not syncing: Attempted to kill init!
Try `/bin/Rebooting in 180 --help' for more information.

So, how can I use coreutils instead of busybox?


-----Original Message-----
From: jsamch at [mailto:jsamch at] On Behalf Of Jean-Samuel
Sent: Friday, January 04, 2008 12:58 AM
To: linuxppc-embedded at; kernelppc at
Subject: RE: File system problem

> Message: 9
> Date: Thu, 3 Jan 2008 18:00:14 +0100
> From: "mojtaba"
> Actually, I removed the console and null created by buildroot and create
> them manually using make node. This time the system freezes at this point.
> "Freeing unused kernel memory: 76k init"

Hi Mojtaba,

I just want to comment on your observation that the file size in /dev
was zero.  This is normal as the device files are 'special' since they
are a mean of abstracting the interface to the kernel.  I had to read
the online book listed below before I could understand the inner
workings of those special files.  If you plan on interfacing your FPGA
with the Linux Kernel, I suggest you read it too, as it is a very
insightful book:

At this point, your system is not frozen, but your init script and
configuration files are probably not all correctly set.  You might
need to read some documentation about buildroot to see what its init
scripts are trying to do.

You might be missing a library or symlink (I got that problem in my
attempt to build the BusyBox root filesystem from scratch).  One way
to go at the problem is to pass the init=/bin/ash or something like
that to your kernel at the boot prompt (you could even make some
trivial 'hello world' program and pass it to the kernel as the init
process).  This way, you can dive right into a shell or your program
and avoid init and its configuration.

After some copying of required libraries in /lib (I'm using uClibc)
and the creation of the required symbolic links, I got my Busybox root
filesystem working on my ML-310 board.

Good luck!


Ph.D. candidate
Integrated Microsystems Laboratory
McGill University, Montréal, QC, CANADA
Web Page:

More information about the Linuxppc-embedded mailing list