2.6.25-rc3 on mpc8548amc doesn't boot

maxime louvel m.louvel at gmail.com
Wed Feb 27 23:37:11 EST 2008


I am still trying to make a 2.6.25-rc3 vanilla kernel boot (an work fine in
a second time) on a mpc8548amc board.
I have add the platform specific stuff from the sources of the current
kernel running on the cards.
What I have basically add is:
- arch/powerpc/platforms/85xx/mpc85xx_amc.c
- arch/powerpc/boot/dts/mpc8548amc.dts
I have also changed the Kconfig and Makefile in the
arch/powerpc/platforms/85xx to make the kernel try to support my board

I have encountered some problem when compiling a uImage that I have
basically solve like this (in arch/powerpc/boot/Makefile)
#$(obj)/4xx.o: BOOTCFLAGS += -mcpu=405
#$(obj)/ebony.o: BOOTCFLAGS += -mcpu=405
#$(obj)/cuboot-taishan.o: BOOTCFLAGS += -mcpu=405
#$(obj)/cuboot-katmai.o: BOOTCFLAGS += -mcpu=405
#$(obj)/treeboot-walnut.o: BOOTCFLAGS += -mcpu=405

I have a gcc-3.4.3 embedded compiler with some stuff specific to the

After the previous hack, I have been able to compile a uImage.

I have tried to boot it and this is what I got:
AMC=> bootm 0x1000000
## Booting image at 01000000 ...
  Image Name:   Linux-2.6.24
  Image Type:   PowerPC Linux Kernel Image (gzip compressed)
  Data Size:    1802038 Bytes =  1.7 MB
  Load Address: 00000000
  Entry Point:  00000000
  Verifying Checksum ... OK
  Uncompressing Kernel Image ... OK

No further messages...

I have recently updated the uboot of the cards (to support the new image
version) and I am capable of booting a image.
This last image has been compiled from a vanilla kernel where I have add the
platform specific stuff (cf beginning of this mail).

Since my image works fine, I have tried to adapt the file I have
added to the 2.6.25-rc3 kernel.

I have made some changes in the arch/powerpc/platforms/85xx/mpc85xx_amc.c
file and in the mpc8548amc.dts file.
I have attached the changes I have done on both files.

Do you have an idea ?


Maxime Louvel
0044 7964 5555 80
43 Allen road
Whitemore reans
WV60AW Wolverhampton
United Kingdom
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://ozlabs.org/pipermail/linuxppc-embedded/attachments/20080227/0beedda7/attachment.htm 
-------------- next part --------------
A non-text attachment was scrubbed...
Type: application/octet-stream
Size: 1262 bytes
Desc: not available
Url : http://ozlabs.org/pipermail/linuxppc-embedded/attachments/20080227/0beedda7/attachment.obj 
-------------- next part --------------
A non-text attachment was scrubbed...
Type: application/octet-stream
Size: 2592 bytes
Desc: not available
Url : http://ozlabs.org/pipermail/linuxppc-embedded/attachments/20080227/0beedda7/attachment-0001.obj 

More information about the Linuxppc-embedded mailing list