On going usb trouble

Joaquin Luna Joaquin.Luna at jdsu.com
Tue Dec 9 02:57:59 EST 2008

I am having some trouble with usb on my custom board based on the
MPC8313ERDB.  I am trying to get a flash drive to mount over usb with
the newest kernel (2.6.27), but I am stuck.  My usb hardware is close to
that of the development board, I am using the internal phy ("utmi_wide"
in the dts file).  I am using an external 24MHz clock.  Since the
development board uses a 48MHz clock, and I am using a 24MHz clock, I
tried to patch the file arch/powerpc/platforms/83xx/ubs.c in the linux
kernel, but the printk's I add do not get printed.  Does that mean my
kernel is not configured properly? What more than USB_EHCI_FSL must I
turn on besides what is needed for flash drives?  I tried turning on
USB_EHCI_HCD_PPC_OF, but I could not even load the device tree with this
option enabled and it did not look like it was aimed at this platform.
Do I need to modify any of the default usb options in the dts file?


Thanks for taking the time to help,

Joaquin Luna

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://ozlabs.org/pipermail/linuxppc-embedded/attachments/20081208/21d47103/attachment.htm>

More information about the Linuxppc-embedded mailing list