SDRAM failures on MPC5200B

Florian A. Voegel fvoegel at
Sat Jul 21 03:39:27 EST 2007


Considering the age of the U-Boot version you're using, it's most likely the problem with the SD-RAM controller of the 5200B. Later U-Boot versions fix this I think by writing a value of 4 to the register at MBAR+0x0190, which does _something_ to resolve the problem. It worked for us. However, we still had problems with SD-RAM in conjunction with other components, so we switched to DDR which has worked flawlessly so far - you might want to consider doing the same.


Florian Voegel

On Fri, 20 Jul 2007 10:40:30 -0500
lokowich <lokowich at> wrote:

> We're working on bringing up a MPC5200B version of our original MPC5200 
> board using U-Boot 1.1.4 configured for Icecube/Lite5200B.  Other than 
> the CPU, the board is identical.  The bootloader crashes just after 
> relocation to RAM, often with a Program Check Exception, typically a 
> memory corruption issue.  I noticed failures at different stages after 
> relocation based on content, suggesting problems with upper SDRAM.  If I 
> force the initram to 1/2 the determined size (64MB instead of 128MB), 
> then everything works well through kernel load and initialization.  
> We've added termination resistors to improve AD signals, to no avail.  
> Memory tests work fine too.  Any help is appreciated.
> Thanks,
> Mark Lokowich
> Systems Engineer
> Advanced Communication Design
> 7901 12th Ave. So.
> Bloomington, MN 55425
> 952-854-4000
> lokowich at
> This email was Anti Virus checked by Astaro Security Gateway.

More information about the Linuxppc-embedded mailing list