[PATCH] [POWERPC] Move generic MPC82xx functions out of ADS-specific

Laurent Pinchart laurent.pinchart at technotrade.biz
Wed Jul 11 17:28:55 EST 2007

On Tuesday 10 July 2007 20:05, Scott Wood wrote:
> On Tue, Jul 10, 2007 at 01:12:45PM +0200, Laurent Pinchart wrote:
> > The non board-specific mpc82xx_halt and mpc82xx_restart functions are
> > defined in arch/powerpc/platforms/82xx/mpc82xx_ads.c. This patch moves
> > them to mpc82xx.c to make them usable by other MPC82xx boards.
> Why are you also moving mpc82xx_ads_show_cpuinfo() to the board file?
> It's not really ADS-specific; it should just be renamed.

For the MPC82xx ADS boards, mpc82xx_ads_show_cpuinfo() prints

Vendor		: Freescale Semiconductor
Machine		: PQ2 ADS PowerPC

The vendor string is hardcoded to "Freescale Semiconductor", and the machine 
string is defined in pq2ads.h. What should show_cpuinfo() print ? Should the 
vendor be the board vendor or the CPU vendor ? What about the machine ?

Laurent Pinchart

More information about the Linuxppc-embedded mailing list