JTAG emulator for MPC8548E (v2)

Laurent Pinchart laurent.pinchart at technotrade.biz
Wed Jan 24 22:06:17 EST 2007

Hi Eugene,

> > The new unit works *mostly* fine. No debugging issue (not that I use it
> > that much anyway, now that the board boots Linux), but still a flash
> > programming issue. Programming the target parallel NOR flash works in
> > slow JTAG mode, but not in faster mode using the internal workspace. I
> > reported the problem several months ago and still haven't received any
> > solution.
> Most likely problem isn't in BDI but in your setup. Depending on
> the particular chip model, to be able use workspace you must have
> initialized memory first. In fact, I'm pretty sure you haven't
> configured chip correctly to make workspace usable. I've been using
> BDI with various PowerPC and MIPS SoCs for many years. It's an excellent
> tool, you just have to use it correctly.

I wish it was that simple. It is probably a target processor configuration 
issue, as I can use the workspace if

a) the target flash has already been programmed with U-Boot
b) the BDI-2000 is misconfigured and fails to stop the target processor at 

I can thus use the workspace when U-Boot initializes the processor.

I had a look at U-Boot code and tried to initialize the processor registers 
with the same values, without luck. I asked Abatron's French distributor for 
technical support, and they haven't been able to help me. They made me try 
lots of different initialization sequences. Several people online sent me 
their configuration file, and none of them worked for me.

So, there must be a configuration problem somewhere, but even Abatron's 
technical support haven't been able to find it. That's why I complained about 
their support in my e-mail.

Best regards,

Laurent Pinchart

More information about the Linuxppc-embedded mailing list