Kernel start hangs after Now booting the kernel

alayrac christophe.alayrac at
Thu Jan 11 04:16:39 EST 2007

I've follwed discusion of Ming, Pradeep, Robert and Ameet on that
mailing list and tried to use teir shared experience to put linux with TEMAC on ML403 board.

I use EDK 8.2 SP2.

So I get on to get kernel source code
and follow instructions to setup configuration.

I've strictely followed instructions and get the following error at boot
time. Only the xparameters_ml403.h has been updated in kernel source
tree to fit the one generated by Xilinx EDK toolchain (with SP2 it is
loaded at:     00400000 004F213C
board data at: 004F0124 004F013C
relocated to:  004050EC 00405104
zimage at:     00405801 004EF0EC
avail ram:     004F3000 01000000

Linux/PPC load: console=ttyS0,9600 root=/dev/xsa2 rw
Uncompressing Linux...done.
Now booting the kernel
The hardware is one made from scratch to include TEMAC, DDR, UART_16550.

The process has worked on ML403 reference design with same procedure,
but with EDK2 SP1 and the all BSP as been copied to the kernel tree.

I'd like to know if some of you face same problems?

I suspect hardware rather than the kernel to be the reason but I did not
succeed to figure it out.

Can any one give me a track?

Does someone have an EDK mhs, and mss files available for an ML403 with
TEMAC design?
If some of you are interested I can send my own mhs and mss file if it
could help.

Just for information I've also tried to apply xuvpro patch, temac patch
(from mvista source code web site) as well as sysace_after_Temac pacth.
The only change is the bauderate, xuvpro patch change it to 38400!

On that last point in that 38400 defalt config how serial link is manage
with a boot command console=ttyS0,9600? 


12 Rue de Blois, BP6744
45067 ORLEANS Cedex 2
Tel :
Fax :
Email : christophe.alayrac at 
Web :

More information about the Linuxppc-embedded mailing list