2.6 kernel hangs after loading device tree

charanya venkatraman charanya.venkatraman at gmail.com
Thu Aug 30 02:38:01 EST 2007

Hi all
       Sorry about the previous mail.Got sent  by mistake.

Iam using the kernel on MPC 8560 and MPC8540 on my custom
board.Mykernel hangs after loading the device tree in both the
processors .There is
no output on the serial port after loading the device tree.Am using U-boot
1.2.0 as the bootloader.After enabling debug in u-boot i could see that the
control is getting transferred to the kernel after which it hangs.Earlier i
tried using 2.6.21 which also hangs at the same point.The config files used
were MPC8540ADS_defconfig and MPC8560ADS_defconfig under powerpc directory.
The changes that were made to the device tree are:
1.The reg and ranges properties of the soc node have been changed to account
for the change in CCSRBAR of my board.
2.Removed the PCI,mdio nodes and ethernet nodes since i dont need support
for these as of now.

I have tried the following console arguments:
MPC8540: bootargs root=/dev/ram rw console=ttyS0,115200
MPC8560:bootargs root=/dev/ram rw console=ttyCPM0,115200

Any help on this issue??

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://ozlabs.org/pipermail/linuxppc-embedded/attachments/20070829/ba76b8f3/attachment.htm 

More information about the Linuxppc-embedded mailing list