8xx SMC1 problem

Björn Östby Bjorn.Ostby at combitech.se
Fri Mar 17 17:55:06 EST 2006

>From: wd at denx.de [mailto:wd at denx.de]
>Sent: den 16 mars 2006 21:10
>To: Björn Östby
>Cc: linuxppc-embedded at ozlabs.org
>Subject: Re: 8xx SMC1 problem
>In message <004Bxxxxx at ratatosk.combitechsystems.com> you wrote
>> First of, I have three serial ports (SMC1, SMC2 and SCC3) and they all
>> work  fine when the console is on SMC1. I have gadgets connected to
>> SMC2 and SCC 3 and now I need SMC1 for yet another device. So I have
>> undefined CONFIG_SE RIAL_CONSOLE in the kernel config and I jump out 
>> of u-boot (which have the console on SMC1) with the argument
>> "console=none".
>And did you make sure that no other process is accessing ttyS0 ?
>> When logging in (via telnet) ttyS0 works no more (but S1 and S2 does).
>> At r andom bootups, it is possible to open the port but it is no good
>> for read o r write.
>> Can anybody give me some advise on how to enable SMC1 but at the same
>> time don't have a console on it?
>We did the same (passing console=null) in a couple of  configurations and
>had  no  problems  >using SMC1 as standard serial port. Try *not* undefining

Ahh, "console=null" worked a lot better than "console=none". 
Problem solved!

>And please keep your line length < 72 characters or so.

I'll see to that.

Björn östby

More information about the Linuxppc-embedded mailing list