USB flashdrive on Motorola MPC5200 (IceCube) board, linux ker nel 2.4.25 (DENX drop)

Roman Fietze roman.fietze at
Mon Jul 31 15:53:50 EST 2006


On Saturday 29 July 2006 00:07, Furxhi, Orges wrote:

> usb.c: USB device not accepting new address=2 (error=-110)

We had that problem on a few of our boards as well.

For the old Icecube exists the possibility to mount two different USB
transceivers, one of them the ISP1107DH, the other one the
P11PAPW. Which one of the two is mounted on your board?

On our own boards we had problems with low speed devices and the
ISP1107, the other transceiver that Freescale used worked
fine. Connecting those low speed devices via a hub worked. Sometimes
it helped to add an additional capacitor to the power lines, but
that's not really a viable solution.

We ended up using a Fairchild USB1T11A, the ISP1107 seemed to have a
problem, we just didn't have luck with them. The Fairchild's are pin
compatible, maybe you just give it a try.


Roman Fietze              Telemotive AG Büro Mühlhausen
Breitwiesen                            73347 Mühlhausen
Tel.: +49(0)7335/18493-45

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : 

More information about the Linuxppc-embedded mailing list