Problems starting /init

David H. Lynch Jr. dhlii at
Thu Jan 5 10:03:11 EST 2006

 I have  a kernel for a new board (Linux, Pico E12/Xilinx V4
PPC405) booting to the point of starting /init.

/init appears to be getting loaded correctly - the execve call seems
happy. But I get no output on the console.

I have tried:


		inside init/main.c immediately before starting /init - works fine.
	starting a "hello World" application written in PPC asm as /init -
works fine. The kernel panics on exit but that is normal, /init is not
supposed to exit.

	starting a c "Hello World" application that uses glibc, fputs, printf,
fwrite, to display a string - again works fine.

	But I can not get busybox to output a thing either run as /init or run
as /bin/sh.

	I have aslo tried /bin/sash - no output.
	I have even cross compiled sash - with all kinds of "I am here"
debugging scattered through main(), If I runn it on a powerbook, I get
what I expect. If I run it as /bin/sh on the e12 I get no output.

	Does anyone even have any ideas what I can look at ?

More information about the Linuxppc-embedded mailing list